[R-br] Última Versão do R em ambiente Linux

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[R-br] Última Versão do R em ambiente Linux

R-br mailing list
Prezados colegas:

Utilizo o sistema operacional linux (Linux Mint 18.3), e gostaria (precisaria) muito de utilizar o R mais novo, versão 3.6.

Embora use o Mint 18.3, tentei seguir as instruções deste link sugeridas para instalar o R no Mint 19, mas não deu certo. Após seguir as instruções, ao rodar:

sudo apt-get install r-base
obtive:

Os pacotes a seguir têm dependências desencontradas:
 r-base : Depende: r-base-core (>= 3.6.1-3bionic) mas não será instalado
          Depende: r-recommended (= 3.6.1-3bionic) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

E ao tentar rodar, por exemplo:
sudo apt-get install r-base-core
obtive:

Os pacotes a seguir têm dependências desencontradas:
 r-base-core : Depende: libc6 (>= 2.27) mas 2.23-0ubuntu11 está para ser instalado
               Depende: libcurl4 (>= 7.28.0) mas não é instalável
               Depende: libicu60 (>= 60.1-1~) mas não é instalável
               Depende: libreadline7 (>= 6.0) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Parece-me assim que instalar a versão mais nova do R não é trivial, pois dependeria de bibliotecas que não estão disponíveis em minha versão do Mint.

Como acredito que haja colegas aqui que também têm o Linux como sistema operacional, gostaria de consultá-los, se têm conseguido utilizar a versão mais nova do R, ou se isto realmente não é possível.  Qualquer dica/informação será muito bem vinda.

Abraços a todos,
Eduardo.






********************************************
Prof. Eduardo Bearzoti
Universidade Federal de Ouro Preto
Departamento de Estatística - ICEB
Campus Morro do Cruzeiro, s/n
35400-000 - Ouro Preto, MG, Brasil




_______________________________________________
R-br mailing list
[hidden email]
https://listas.inf.ufpr.br/cgi-bin/mailman/listinfo/r-br
Leia o guia de postagem (http://www.leg.ufpr.br/r-br-guia) e forneça código mínimo reproduzível.
Reply | Threaded
Open this post in threaded view
|

Re: [R-br] Última Versão do R em ambiente Linux

R-br mailing list
Malgrado meu Linux seja Ubuntu, as instruções acima citadas valem para ambos, e posso lhe assegurar que funcionam:

csrabak@salsicha:~$ R --version
R version 3.6.1 (2019-07-05) -- "Action of the Toes"
Copyright (C) 2019 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under the terms of the
GNU General Public License versions 2 or 3.
For more information about these matters see
https://www.gnu.org/licenses/.


HTH
--
Cesar Rabak

On Mon, Nov 11, 2019 at 10:59 PM Eduardo Bearzoti por (R-br) <[hidden email]> wrote:
Prezados colegas:

Utilizo o sistema operacional linux (Linux Mint 18.3), e gostaria (precisaria) muito de utilizar o R mais novo, versão 3.6.

Embora use o Mint 18.3, tentei seguir as instruções deste link sugeridas para instalar o R no Mint 19, mas não deu certo. Após seguir as instruções, ao rodar:

sudo apt-get install r-base
obtive:

Os pacotes a seguir têm dependências desencontradas:
 r-base : Depende: r-base-core (>= 3.6.1-3bionic) mas não será instalado
          Depende: r-recommended (= 3.6.1-3bionic) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

E ao tentar rodar, por exemplo:
sudo apt-get install r-base-core
obtive:

Os pacotes a seguir têm dependências desencontradas:
 r-base-core : Depende: libc6 (>= 2.27) mas 2.23-0ubuntu11 está para ser instalado
               Depende: libcurl4 (>= 7.28.0) mas não é instalável
               Depende: libicu60 (>= 60.1-1~) mas não é instalável
               Depende: libreadline7 (>= 6.0) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Parece-me assim que instalar a versão mais nova do R não é trivial, pois dependeria de bibliotecas que não estão disponíveis em minha versão do Mint.

Como acredito que haja colegas aqui que também têm o Linux como sistema operacional, gostaria de consultá-los, se têm conseguido utilizar a versão mais nova do R, ou se isto realmente não é possível.  Qualquer dica/informação será muito bem vinda.

Abraços a todos,
Eduardo.






********************************************
Prof. Eduardo Bearzoti
Universidade Federal de Ouro Preto
Departamento de Estatística - ICEB
Campus Morro do Cruzeiro, s/n
35400-000 - Ouro Preto, MG, Brasil



_______________________________________________
R-br mailing list
[hidden email]
https://listas.inf.ufpr.br/cgi-bin/mailman/listinfo/r-br
Leia o guia de postagem (http://www.leg.ufpr.br/r-br-guia) e forneça código mínimo reproduzível.

_______________________________________________
R-br mailing list
[hidden email]
https://listas.inf.ufpr.br/cgi-bin/mailman/listinfo/r-br
Leia o guia de postagem (http://www.leg.ufpr.br/r-br-guia) e forneça código mínimo reproduzível.
Reply | Threaded
Open this post in threaded view
|

Re: [R-br] Última Versão do R em ambiente Linux

R-br mailing list
In reply to this post by R-br mailing list
Tente isso:


$ sudo nano /etc/apt/sources.list

Copie a linha abaixo dentro do documento e salve (control+x y):


Isto irá atualizar o repositório do R no sua source.list


$ sudo apt update
$ sudo apt install r-base-core

Se houver um problema com uma chave de autenticação, rode isso

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9

Espero que dê certo

Abraço


daniel



Daniel Tiezzi, MD, PhD
Professor Associado
Departamento de Ginecologia e Obstetrícia
Setor de Mastologia e Oncologia Ginecológica
Faculdade de Medicina de Ribeirão Preto - USP
Tel.: 16 3602-2488
[hidden email]



On 11 Nov 2019, at 22:56, Eduardo Bearzoti por (R-br) <[hidden email]> wrote:

r-base : Depende: r-base-core (>= 3.6.1-3bionic) mas não será instalado
          Depende: r-recommended (= 3.6.1-3bionic) mas não será instalado


_______________________________________________
R-br mailing list
[hidden email]
https://listas.inf.ufpr.br/cgi-bin/mailman/listinfo/r-br
Leia o guia de postagem (http://www.leg.ufpr.br/r-br-guia) e forneça código mínimo reproduzível.